CloudForms Fix SmartState for VMWare 6.7

VMWare made significant changes of the API’s with the release of 6.7 and as such the way we mount vmdk and read then has changed, you will see once you upgrade that CloudForms can no longer perform a SSA, the error in the User interface will look similar to this.

To get around this issue we simply need to upgrade 2 gems, SSH as root into any CloudForms appliance that can perform the SSA and run the following

gem install vmware_web_service

This will also install a dependency gem we need ffi-vix_disk_lib, at the time of writing this the version needed are

vmware_web_service 0.4.1

ffi-vix_disk_lib 1.0.5

Leave a Reply

Your email address will not be published. Required fields are marked *